Facing issue when installing MITMF on Kali Linux 2019.4

I am unable to install MITMf framework on my kali machine,

initially i try to install it using : apt-get install mitmf
command, but i get error that unable to locate.

then I cloned from the git repo like this :
git clone https://github.com/byt3bl33d3r/MITMf.git

and I found that pip2 is not comes with kali 2019.4, so i installed it using this command:
apt-get install python-pip

and then when I am trying to install the requirements of MITMf using requirements.txt using this command:
pip install -r requirements.txt

after few minutes I encountered an error!

I am using kali Linux 2019.4 latest edition 64bit with xfce desktop environment.

Any Help would be appreciated.

Hello @MrRobot ,
Nice to see you being productive here in the community. I have found the installation Wiki for MITMF here https://github.com/byt3bl33d3r/MITMf/wiki/Installation looks like there is a few steps you may or may not have overlooked. Let me know how it works out.

Issue is solved!

Actually! when i was running mitmf

it is showing bdfactory module not found.

But then I managed to install it using this command:

cd MITMf && git submodule init && git submodule update --recursive
1 Like

Good Job! I love seeing someone come with a problem, stick with it then figure it out. Now that is how you level up and progress.