Termux Hacks Guide[2019 and beyond]

If you think Ethical Hacking is only restricted to use of Desktops or Laptops for that matter, think again because if you have observed the way I did, third-party developers have been playing a huge role in filling gaps during each stage of Technological Evolution. In this guide we will learn about various Termux hacks, termux tutorials, termux wifi hack commands list, termux guide, termux tools, apk & packages & termux uses.

A similar Third Party developer called “Anonymous” has developed a Linux-self contained App called “ Termux ” which is used to install Linux based apps in Android and helps in running pure Linux apps in Android.

Now you will be wondering why do I need LINUX apps?

LINUX has a history of being a programmer-centric so the purpose of TERMUX app is to help Cyber Security professionals in monitoring systems and Cyber Security practices like Penetration Testing through Mobile Networks.

Compared to the millions of apps in Google Play Store, which in Mr. Peters words are considered “ports” of Linux applications which are made in an Android way, TERMUX is a pure LINUX app having a platform independent architecture making it portable and compatible with even Windows.

Before we continue, a simple line explanation on its UI: its UI is command line interface based.

Think MS-DOS and all those computers of yesteryears which came before Windows and MacOS and you will know what I am talking about. No shiny icons or instructions. Just you and your skills.

PS. I have combined the info available on various websites in one place in proper sequence to make the process less time-consuming.

Lets Begin
pkg upgrade && touch .hushlogin && pkg install python cmake nodejs ruby golang nmap hydra tsu ~ if you can not install tsu here then remove it and install it after adding the root repo.
pkg update && pkg upgrade -y && pkg install wget curl openssh git -y
after that
mkdir notes gh homework temp
Next is configuring the dotfiles
cd gh && git clone https://github.com/konradit/dotfiles.git && cp dotfiles/bashrc ~/.bashrc
pkg install coreutils termux-api termux-exec termux-tools grep tree termux-widget termux-auth termux-boot play-audio libandroid-support vim ncurses-utils openssh gpg w3m && pkg upgrade
termux-setup-storage – plz grant the permission when it pops up
THAT IS IT! now restart the app and things should look something like this:

if you have root type:

After allowing root access it should look like this:

if you want sudo then run this: https://gitlab.com/st42/termux-sudo

if you want to add root repos then :
pkg install root-repo termux-root-packages ~ Remove termux-root-package/s from this command if any errors are encountered.
These root repos will let you install the following :

  1. aircrack-ng
  2. arp-scan
  3. tcpdump

A great person had once said: “With great power comes great responsibility” . Maintaining peace in Society is our responsibility. That’s why when you use apps like TERMUX do it for educational purposes and not for causing harm to anyone. Even before you think about committing such acts, spare a thought for your parents.

Happy Hacking!


You also need the unstable repo to get a few of these applications and you never mentioned installing it.

1 Like

Since you noticed he was missing something, how about give an solution to what you see as an mistake.

1 Like

Ok not a problem just didn’t think of it.

AFAIK Metasploit comes from the unstable repo in Termux though I could be wrong.
It explains how to install this repo when you start up Termux.

pkg install unstable-repo 

To install the unstable repo


Guys please help, everytime I open termux app something appears after the date and time it says “thefuck : command not found”. Please help me guys i hate it xD

@SchwarzSterben please refrain from using abusive language , as for you problem you need to copy paste the entire error that you are receiving , so that we can help you . plz us ethe 6th icon in the reply editor interface to put in your code . It Will Appear like this!

1 Like

my bad man, i solved it already, thanks anyway. I have another concern about bash: /data/data/com.termux/files/usr/bin/ tput: Permission denied everytime i run tsu that error appears.

it wasn’t an abusive language its an actual package called thef*** you can google it for proof.

1 Like

Hmm could be a problem with your su binary…which rooting solution are you using?

I am using SuperSu, I am only having problem with tsu and tsudo. su command works fine.

1 Like

Say, how did you fix that? The thef*** one? Also, when i followed the instructions, it came up
bash: thefuck: command not found
u0_a***@localhost [~]: tsu
/data/data/com.termux/files/usr/bin/tsu: 144: exec: : Permission denied what do i do?

1 Like

The solution to “thefuck : command not found” is to install thefuck :rofl:
You can install it using this:
pip3 install thefuck
And thanks a lot for the post


The fuck command not found i tried pip3 install thefuck
Noy working i also edit bash.bashrc
No use
Please help thanks

The fuck command not found i tried pip3 install thefuck
Noy working i also edit bash.bashrc
No use
Please help thanks

If you face this error: pip3 command not found

Then run this command: apt-get install python3-pip

Also try to run like this:
python3 -m pip install thefuck

Broi try but getting error please review thanks

ERROR: Command errored out with exit status 1:
command: /data/data/com.termux/files/usr/bin/python3 -u -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/data/data/com.termux/files/usr/tmp/pip-install-az9on6ia/psutil/setup.py’"’"’; file=’"’"’/data/data/com.termux/files/usr/tmp/pip-install-az9on6ia/psutil/setup.py’"’"’;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ install --record /data/data/com.termux/files/usr/tmp/pip-record-qwollmw0/install-record.txt --single-version-externally-managed --compile

cwd: /data/data/com.termux/files/usr/tmp/pip-install-az9on6ia/psutil/
Complete output (44 lines):
running install
running build
running build_py
creating build
creating build/lib.linux-aarch64-3.8
creating build/lib.linux-aarch64-3.8/psutil
copying psutil/_psaix.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/init.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/_pswindows.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/_pssunos.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/_psposix.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/_compat.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/_pslinux.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/_psosx.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/_psbsd.py -> build/lib.linux-aarch64-3.8/psutil
copying psutil/_common.py -> build/lib.linux-aarch64-3.8/psutil
creating build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_connections.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_contracts.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_aix.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_system.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_osx.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_windows.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_sunos.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_memory_leaks.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_unicode.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/runner.py -> build/lib.linux-aarch64-3.8/psutil/testsopying psutil/tests/main.py -> build/lib.linux
copying psutil/tests/test_linux.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_bsd.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/init.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_process.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_misc.py -> build/lib.linux-aarch64-3.8/psutil/tests
copying psutil/tests/test_posix.py -> build/lib.linux-aarch64-3.8/psutil/tests
running build_ext
building ‘psutil._psutil_linux’ extension
creating build/temp.linux-aarch64-3.8
creating build/temp.linux-aarch64-3.8/psutil
aarch64-linux-android-clang -Wno-unused-result -Wsign-compare -Wunreachable-code -DNDEBUG -g -fwrapv -O3 -Wall -fstack-protector-strong -Oz -fstack-protector-strong -Oz -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=567 -DPSUTIL_LINUX=1 -DPSUTIL_ETHTOOL_MISSING_TYPES=1 -I/data/data/com.termux/files/usr/include/python3.8 -c psutil/_psutil_common.c -o build/temp.linux-aarch64-3.8/psutil/_psutil_common.o
unable to execute ‘aarch64-linux-android-clang’: No such file or directory
building ‘psutil._psutil_posix’ extension
aarch64-linux-android-clang -Wno-unused-result -Wsign-compare -Wunreachable-code -DNDEBUG -g -fwrapv -O3 -Wall -fstack-protector-strong -Oz -fstack-protector-strong -Oz -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=567 -DPSUTIL_LINUX=1 -DPSUTIL_ETHTOOL_MISSING_TYPES=1 -I/data/data/com.termux/files/usr/include/python3.8 -c psutil/_psutil_common.c -o build/temp.linux-aarch64-3.8/psutil/_psutil_common.o
unable to execute ‘aarch64-linux-android-clang’: No such file or directory
error: command ‘aarch64-linux-android-clang’ failed with exit status 1
ERROR: Command errored out with exit status 1: /data/data/com.termux/files/usr/bin/python3 -u -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/data/data/com.termux/files/usr/tmp/pip-install-az9on6ia/psutil/setup.py’"’"’; file=’"’"’/data/data/com.termux/files/usr/tmp/pip-install-az9on6ia/psutil/setup.py’"’"’;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ install --record /data/data/com.termux/files/usr/tmp/pip-record-qwollmw0/install-record.txt --single-version-externally-managed --compile Check the logs for full command output.

apt-get install python3-pip
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package python3-pip

1 Like

Somehow i install the fuck but when i start termux getting this please reply

Sat Dec 7 16:48:48 IST 2019
Traceback (most recent call last):
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/psutil/_common.py”, line 296, in wrapper
return cache[key]
KeyError: ((’/proc’,), frozenset())

During handling of the above exception, another exception occurred:

Traceback (most recent call last):File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/psutil/_pslinux.py”, line 312, in
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/psutil/_common.py”, line 298, in wrapper
ret = cache[key] = fun(*args, **kwargs)
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/psutil/_pslinux.py”, line 279, in set_scputimes_ntuple
with open_binary(’%s/stat’ % procfs_path) as f:
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/psutil/_common.py”, line 604, in open_binary
return open(fname, “rb”, **kwargs)
PermissionError: [Errno 13] Permission denied: ‘/proc/stat’
Traceback (most recent call last):

Traceback (most recent call last):
File “/data/data/com.termux/files/usr/bin/thefuck”, line 6, in
from thefuck.entrypoints.main import main
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/thefuck/entrypoints/main.py”, line 11, in
from …shells import shell # noqa: E402
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/thefuck/shells/init.py”, line 52, in
shell = _get_shell_from_env() or _get_shell_from_proc()
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/thefuck/shells/init.py”, line 45, in _get_shell_from_proc
proc = proc.parent()
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/psutil/init.py”, line 662, in parent
ctime = self.create_time()
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/psutil/init.py”, line 824, in create_time
self._create_time = self._proc.create_time()
File “/data/data/com.termux/files/usr/lib/python3.8/site-packages/psutil/_pslinux.py”, line 1519, in wrapper
raise AccessDenied(self.pid, self._name)
psutil.AccessDenied: psutil.AccessDenied (pid=12235, name=‘thefuck’)
[email protected] [~]:
[email protected] [~]: tsu
Sat Dec 7 16:49:08 IST 2019
[email protected] [~]:

1 Like

May be you are using incompatible python version, try to install python 3.7.4 version.

In latest version of python, it takes some time for developers of modules to make it compatible with latest python version.

1 Like

Also try to download offline module if case any module/dependencies failed to install.

This is the link where you can download offline modules

Install offline module like this:

python3 -m pip install module_name_downloaded_file.whl
1 Like